Ernstige kwetsbaarheid ontdekt in PHPMailer

PHPMailer blijkt een ernstige kwetsbaarheid te bevatten die aanvallers de mogelijkheid geeft op afstand eigen code uit te voeren op systemen. PHPMailer wordt onder andere in WordPress, Drupal, 1CRM, SugarCRM, Yii en Joomla gebruikt.

PHPMailerPHPMailer is een populaire PHP library voor het versturen van e-mail. Wereldwijd wordt de library naar schatting door ruim 9 miljoen gebruikers gebruikt. Een groot aantal populaire websites maakt gebruik van PHPMailer om e-mails te kunnen versturen. De tool wordt onder andere in gebruikt om geautomatiseerde e-mails te versturen na het invoeren van contact-, feedback- of registratieformulieren en het aanvragen van een nieuw wachtwoord.

De kwetsbaarheid is ontdekt door Dawid Golunski van Legal Hackers en is geïdentificeerd als CVE-2016-10033. Golunski heeft de kwetsbaarheid bij de ontwikkelaars van PHPMailer gemeld, die het beveilingslek in PHPMailer 5.2.18 hebben verholpen. Alle eerdere versies van PHPMailer zijn kwetsbaar.

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Verplichte velden zijn gemarkeerd met *